This project is read-only.

What is required to build.

Dec 24, 2011 at 11:18 PM

Is there a full list of everything required to build this?  What about download links?

I've got the 3.0.0.0 version, but been trying to compile the code myself for research.  Been trying now for about 1.5 days and I thought I had everything installed but I'm really not getting anywhere...

R:\Projects\Liberty\MetroLiberty\MetroLiberty.csproj : error  : Unable to read the project file 'MetroLiberty.csproj'.
R:\Projects\Liberty\MetroLiberty\MetroLiberty.csproj(92,3): The imported project "C:\Program Files\MSBuild\Microsoft\WindowsXaml\v1.0\Microsoft.Windows.UI.Xaml.CSharp.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.

And when trying to build I get many errors/warnings, these are the last ones in the list...

Error    20    The type or namespace name 'STFSPackage' could not be found (are you missing a using directive or an assembly reference?)    R:\Projects\Liberty\Liberty\MainWindow.xaml.cs    384    42    Liberty
Warning    21    Could not resolve this reference. Could not locate the assembly "X360". Check to make sure the assembly exists on disk. If this reference is required by your code, you may get compilation errors.    Liberty
Warning    22    The referenced component 'X360' could not be found.    

I'm quite new to C# so forgive me if the answer is too obvious...

Dec 25, 2011 at 1:55 AM

Microsoft visual studio 2011 dev preview is required as well as .net framework 4.5. Installing the dev preview will install both. You will also need Expression Blend SDK installed. Here is a download link for Microsoft visual studio 2011 dev preview http://www.microsoft.com/download/en/details.aspx?id=27543

I assume you already have a version of Microsoft visual studio installed? I do not know if the dev preview is required or not. Try downloading the latest source or an earlier source then trying again.

Dec 25, 2011 at 2:27 AM
Edited Dec 25, 2011 at 2:29 AM

Ahh... Damn, I'm still on XP here with Visual Studio 2010.  To install MS Visual Studio 2011 or .net framework 4.5 you must have at least Windows 7...  So Windows 7 is a requirement to build it as well.  Well more specifically, one of the following operating systems:

  • Windows 7 (x86 and x64)
  • Windows 8 (x86 and x64)
  • Windows Server 2008 R2 (x64)
  • Windows Server Developer Preview (x64)

Maybe Microsoft will suddenly feel the urge to be very generous and send me a new system with Windows 8 pre-installed...  but then again there is still that whole thing about world peace and blah blah blah...

At least I have source code... ;)

Thanks you, and thanks to all the developers.

And have a Merry Christmas. ;)

Jan 30, 2012 at 10:21 AM
Edited Jan 30, 2012 at 10:22 AM

That project is just something I mess around with when I have time and I'm on my laptop. It requires VS11 Dev Preview and Windows 8 to work on it. It will always fail to load, but the rest of liberty will load fine. So don't worry, you can just ignore it.

 

As for the STFSPackage error make sure the X360 dll has been added to the main projects references. (For X360, get it from the Liberty download zip on the download section.

Jan 30, 2012 at 12:04 PM

Aha!  It works now. ;)  Had to add X360 like you said.  I'm not used to using Visual Studio or C# yet...  I guess I just gave up too soon.

Thanks a lot for the help.